ΑΕΠΠ 2013- ΕΝΑΛΛΑΚΤΙΚΕΣ ΑΠΑΝΤΗΣΕΙΣ

2
Εναλλακτικές Λύσεις ΑΕΠΠ 2013 A4α B2. Για i από 1 μέχρι 99 Για j από i+1 μέχρι 100 Διάβασε Π[i,j] Τέλος_επανάληψης Τέλος_επανάληψης Για i από 1 μέχρι 99 Για j από i μέχρι 99 Διάβασε Π[i,j+1] Τέλος_επανάληψης Τέλος_επανάληψης Για i από 1 μέχρι 99 j ← i +1 Όσο j<=100 επανάλαβε Διάβασε Π[i,j] j ← j +1 Τέλος_επανάληψης Τέλος_επανάληψης Για i από 1 μέχρι 100 Για j από 1 μέχρι 100 done ← i<j Όσο done=Αληθής επανάλαβε Διάβασε Π[i,j] done ← Ψευδής Τέλος_επανάληψης Τέλος_επανάληψης Τέλος_επανάληψης Για j από 2 µέχρι 100 Για i από 1 µέχρι j-1 ∆ιάβασε Π[i,j] Τέλος_επανάληψης Τέλος_επανάληψης Για i από 1 μέχρι 100 Για j από 1 μέχρι 100 done ← Ψευδής Όσο done=Ψευδής και i<j επανάλαβε Διάβασε Π[i,j] done ← Αληθής Τέλος_επανάληψης Τέλος_επανάληψης Τέλος_επανάληψης κ←1 Για i από 1 μέχρι 100 Αν Π[i]=Αληθής τότε Π[κ] ← Π[i] κ ← κ+1 Τέλος_Αν Τέλος_επανάληψης Για i από κ μέχρι 100 Π[i] ← Ψευδής Τέλος_επανάληψης κ 0 Για i από 1 μέχρι 100 Αν Π[i]=ΑΛΗΘΗΣ τότε κκ+1 Τέλος_αν Τέλος_επανάληψης Για i από 1 μέχρι κ Π[i]ΑΛΗΘΗΣ Τέλος_επανάληψης Για i από κ+1 μέχρι 100 Π[i]ΨΕΥΔΗΣ Τέλος_επανάληψης κ 0 Για i από 1 μέχρι 100 Αν Π[i]=ΑΛΗΘΗΣ τότε κκ+1 Τέλος_αν Τέλος_επανάληψης Για i από 1 μέχρι 100 Αν i< κ τότε Π[i]ΑΛΗΘΗΣ αλλιώς Π[i]ΨΕΥΔΗΣ Τέλος_αν Τέλος_επανάληψης i←1 j←100 Όσο i<j επανάλαβε Αν Π[i]=Αληθής τότε i ← i+1 Τέλος_αν Αν Π[j]=Ψευδής τότε j ← j-1 Τέλος_αν Αν Π[i]=Ψευδής και Π[j]=Αληθής τότε temp Π[i] Π[i] Π[j] Π[j] temp i ← i+1 j ← j-1 Τέλος_αν Τέλος_επανάληψης 1 2 3 4 5 3 4 1 2 Νέο 6

description

Panellinies 2013

Transcript of ΑΕΠΠ 2013- ΕΝΑΛΛΑΚΤΙΚΕΣ ΑΠΑΝΤΗΣΕΙΣ

Page 1: ΑΕΠΠ 2013- ΕΝΑΛΛΑΚΤΙΚΕΣ ΑΠΑΝΤΗΣΕΙΣ

Εναλλακτικές Λύσεις ΑΕΠΠ 2013

A4α

B2.

Για i από 1 μέχρι 99

Για j από i+1 μέχρι 100

Διάβασε Π[i,j]

Τέλος_επανάληψης

Τέλος_επανάληψης

Για i από 1 μέχρι 99

Για j από i μέχρι 99

Διάβασε Π[i,j+1]

Τέλος_επανάληψης

Τέλος_επανάληψης

Για i από 1 μέχρι 99

j ← i +1

Όσο j<=100 επανάλαβε

Διάβασε Π[i,j]

j ← j +1

Τέλος_επανάληψης

Τέλος_επανάληψης

Για i από 1 μέχρι 100

Για j από 1 μέχρι 100

done ← i<j

Όσο done=Αληθής επανάλαβε

Διάβασε Π[i,j]

done ← Ψευδής

Τέλος_επανάληψης

Τέλος_επανάληψης

Τέλος_επανάληψης

Για j από 2 µέχρι 100 Για i από 1 µέχρι j-1 ∆ιάβασε Π[i,j] Τέλος_επανάληψης Τέλος_επανάληψης

Για i από 1 μέχρι 100

Για j από 1 μέχρι 100

done ← Ψευδής

Όσο done=Ψευδής και i<j επανάλαβε

Διάβασε Π[i,j]

done ← Αληθής

Τέλος_επανάληψης

Τέλος_επανάληψης

Τέλος_επανάληψης

κ←1

Για i από 1 μέχρι 100

Αν Π[i]=Αληθής τότε

Π[κ] ← Π[i]

κ ← κ+1

Τέλος_Αν

Τέλος_επανάληψης

Για i από κ μέχρι 100

Π[i] ← Ψευδής

Τέλος_επανάληψης

κ � 0

Για i από 1 μέχρι 100

Αν Π[i]=ΑΛΗΘΗΣ τότε

κ�κ+1

Τέλος_αν

Τέλος_επανάληψης

Για i από 1 μέχρι κ

Π[i]�ΑΛΗΘΗΣ

Τέλος_επανάληψης

Για i από κ+1 μέχρι 100

Π[i]�ΨΕΥΔΗΣ

Τέλος_επανάληψης

κ � 0

Για i από 1 μέχρι 100

Αν Π[i]=ΑΛΗΘΗΣ τότε

κ�κ+1

Τέλος_αν

Τέλος_επανάληψης

Για i από 1 μέχρι 100

Αν i< κ τότε

Π[i]�ΑΛΗΘΗΣ

αλλιώς

Π[i]�ΨΕΥΔΗΣ

Τέλος_αν

Τέλος_επανάληψης

i←1

j←100

Όσο i<j επανάλαβε

Αν Π[i]=Αληθής τότε

i ← i+1

Τέλος_αν

Αν Π[j]=Ψευδής τότε

j ← j-1

Τέλος_αν

Αν Π[i]=Ψευδής και Π[j]=Αληθής τότε

temp� Π[i]

Π[i] � Π[j]

Π[j] � temp

i ← i+1

j ← j-1

Τέλος_αν

Τέλος_επανάληψης

1 2

3 4 5

3

4

1 2

Νέο

6

Page 2: ΑΕΠΠ 2013- ΕΝΑΛΛΑΚΤΙΚΕΣ ΑΠΑΝΤΗΣΕΙΣ

Εναλλακτικές Λύσεις ΑΕΠΠ 2013

Γ3.

Για i από 1 μέχρι 30

Εμφάνισε ΚΩΔ[i]

Αν ΜΟ[i,1]>2 Ή ΜΟ[i,2]>4 τότε

Εμφάνισε "Εκτός ορίων"

αλλιώς_αν ΜΟ[i,1]>1,8 Ή ΜΟ[i,2]>3,6 τότε

Εμφάνισε "Κοντά στα όρια"

αλλιώς

Εμφάνισε "Χαμηλός SAR"

Τέλος_αν

Τέλος_επανάληψης

Για i από 1 μέχρι 30

Εμφάνισε ΚΩΔ[i]

Αν ΜΟ[i, 1] <= 1,8 τότε

Αν ΜΟ[i, 2]<= 3,6 τότε

εμφάνισε “Χαμηλός SAR”

αλλιώς_αν ΜΟ[i, 2]<= 4 τότε

εμφάνισε “Κοντά στα όρια”

αλλιώς

εμφάνισε “Εκτός ορίων”

Τέλος_αν

αλλιώς_αν ΜΟ[i, 1] <= 2 τότε

Αν ΜΟ[i, 2]<= 4 τότε

εμφάνισε “Κοντά στα όρια”

αλλιώς

εμφάνισε “Εκτός ορίων”

Τέλος_αν

αλλιώς

Εμφάνισε “Εκτός ορίων”

Τέλος_αν

Τέλος_επανάληψης

Για i από 1 μέχρι 30

Αν ΜΟ[i,1]<=1.8 τότε

μνμ1 ← “ Χαμηλός SAR”

αλλιώς_αν ΜΟ[i,1]<=2 τότε

μνμ1 ← “ Κοντά στα όρια”

αλλιώς

μνμ1 ← “ Εκτός ορίων”

Τέλος_Αν

Αν ΜΟ[i,2]<=3.6 τότε

μνμ2 ← “ Χαμηλός SAR”

αλλιώς_αν ΜΟ[i,2]<=4 τότε

μνμ2 ← “ Κοντά στα όρια”

αλλιώς

μνμ2 ← “Εκτός ορίων”

Τέλος_Αν

Αν μνμ1 < μνμ2 τότε

Εμφάνισε ΚΩΔ[i], μνμ1

αλλιώς

Εμφάνισε ΚΩΔ[i], μνμ2

Τέλος_αν

Τέλος_επανάληψης

!ΕΥΡΕΣΗ ΠΕΔΙΟΥ ΣΤΟ ΟΠΟΙΟ ΑΝΗΚΕΙ Η ΠΕΡΙΟΧΗ ΚΕΦΑΛΗΣ

Για i από 1 μέχρι 30

Αν ΜΟ[i, 1] ≤ 1.8 τότε

ΠΕΔΙΟ_ΚΕΦ ← 1

αλλιώς_αν ΜΟ[i, 1] ≤ 2 τότε

ΠΕΔΙΟ_ΚΕΦ ← 2

αλλιώς

ΠΕΔΙΟ_ΚΕΦ ← 3

Τέλος_αν

!ΕΥΡΕΣΗ ΠΕΔΙΟΥ ΣΤΟ ΟΠΟΙΟ ΑΝΗΚΕΙ ΤΟ ΑΚΡΟ

Αν ΜΟ[i, 2] ≤ 3.6 τότε

ΠΕΔΙΟ_ΑΚΡ ← 1

αλλιώς_αν ΜΟ[i, 1] ≤ 4 τότε

ΠΕΔΙΟ_ΑΚΡ ← 2

αλλιώς

ΠΕΔΙΟ_ΑΚΡ ← 3

Τέλος_αν

!ΕΥΡΕΣΗ ΓΕΝΙΚΟΥ ΠΕΔΙΟΥ

Αν ΠΕΔΙΟ_ΚΕΦ ≥ ΠΕΔΙΟ_ΑΚΡ τότε

ΠΕΔΙΟ ← ΠΕΔΙΟ_ΚΕΦ

αλλιώς

ΠΕΔΙΟ ← ΠΕΔΙΟ_ΑΚΡ

Τέλος_αν

Εμφάνισε ΚΩΔ[i]

Αν ΠΕΔΙΟ = 1 τότε

Εμφάνισε "ΧΑΜΗΛΟΣ SAR"

αλλιώς_αν ΠΕΔΙΟ = 2 τότε

Εμφάνισε "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"

αλλιώς

Εμφάνισε "ΕΚΤΟΣ ΟΡΙΩΝ"

Τέλος_αν

Τέλος_επανάληψης

Για i από 1 μέχρι 30

Εμφάνισε ΚΩΔ[i]

Αν ΜΟ[i,1]<=1,8 KAI ΜΟ[i,2]<=3.6 τότε

Εμφάνισε " Χαμηλός SAR"

αλλιώς_αν ΜΟ[i,1]<=2 KAI ΜΟ[i,2]<=4 τότε

Εμφάνισε "Κοντά στα όρια"

αλλιώς

Εμφάνισε "Εκτός ορίων"

Τέλος_αν

Τέλος_επανάληψης

1 2

3 4

5